[Blindapple] Running the Apple2EE emulator on a Mac

James Dean jd040189 at gmail.com
Sat Oct 12 16:54:28 EDT 2013


I am trying to run this emulator on my MacBook running OS X 10.8.5.

I extracted the contents of the zip archive to my home folder which is called "RedFlame." I changed the folder name from the name of the zip package to simply "mess." I figured this would make it easier to access via the terminal. I also copied the SDL.frameworks folder found in the archive to /library/frameworks, this of course being the library folder found in the root of the drive, not the one in my home folder, as the instructions dictate.

so, the contents of the zip package is stored in /users/redflame/mess.

The Mac instructions say to type ./mess64 apple2ee -flop1 disks/egames.dsk

I type this exactly as shown into terminal. I did not paste. This is what I get.

Last login: Sat Oct 12 13:31:26 on ttys000
JD-Macintosh:~ redflame$ ./mess64 apple2ee -flop1 disks/egames.dsk
-bash: ./mess64: No such file or directory
JD-Macintosh:~ redflame$

I'm half-way smart, so I tried /users/redflame/mess then pressed return and got:

-bash: /users/redflame/mess: is a directory

Ok, so, assuming this works like DOS in windows, terminal should now be pointing to that folder. so I tried "mess64 apple2ee -flop1 disks/egames.dsk

-bash: mess64: command not found

Alright, so this apparently doesn't work like DOS in windows. This is what I tried last.

/users/redflame/mess/mess64 apple2ee -flop1 disks/egames.dsk

JD-Macintosh:~ redflame$ /users/redflame/mess/mess64 apple2ee disks/egames.dsk
"disks/egames.dsk" approximately matches the following
supported software items (best match first):
JD-Macintosh:~ redflame$ 

Um, where are these matches? Even if they were presented, I wouldn't know how to tell terminal which one I wanted it to use. So, this is where I am stuck.

I did something else before and it told me that a bunch of files, some with a .cdr extension were missing. Error, the system cannot be run, but I don't remember what I did to produce that and so this is as far as I have gotten.

I did manage to get this to work on my Windows XP professional Virtual Machine in VMWare Fusion, but the echo2 speech stutters quite a bit. I assume this is because the emulator is recording to the "session.wav" file, but I'm not sure. I thought that running it on the mac would solve this problem. I know that at least one other person got it to work on his Mac, so I just want this to work.

I know this is long, but I have attempted to provide complete steps so that somebody can help without having to ask a bunch of questions that have probably already been answered.

Thanks in advance for any help.


More information about the BlindApple mailing list